[Gemfile] Ruby1.8.4 で Ruby on Rails チュートリアル

[Gemfile] Ruby1.8.4 で Ruby on Rails チュートリアルredMineとかいろいろあったんでRuby 1.8.4の環境で rails チュートリアルをデプロイするために変更したGemfileです。なんか地味にたいへんだったんで、だれかの役にたてば。。。

環境:
Ruby 1.8.4
Rails 3.2.16 rails チュートリアル and ed

Gemfile

source 'https://rubygems.org'
gem 'rails', '3.2.16'
gem 'bootstrap-sass', '>= 3'
gem 'bcrypt-ruby', '3.0.1'
gem 'faker', '1.0.1'
gem 'will_paginate', '3.0.3'
gem 'bootstrap-will_paginate', '0.0.6'
gem 'jquery-rails', '2.0.2'
# gem 'celluloid', '0.6.2'
group :development, :test do
gem 'sqlite3', '1.3.5'
gem 'rspec-rails', '2.11.0'
# gem 'guard-rspec', '1.2.1'
# gem 'guard-spork', '1.2.0'
gem 'childprocess', '0.3.6'
gem 'spork', '0.9.2'
end
# Gems used only for assets and not required
# in production environments by default.
group :assets do
gem 'sass-rails', '3.2.5'
gem 'coffee-rails', '3.2.2'
gem 'uglifier', '1.2.3'
end
group :test do
gem 'nokogiri', '1.5.10'
gem 'rubyzip', '0.9.5'
gem 'capybara', '2.0.3'
gem 'factory_girl_rails', '~> 1.0'
gem 'cucumber-rails', '1.2.1', :require => false
gem 'database_cleaner', '0.7.0'
# gem 'launchy', '2.1.0'
# gem 'rb-fsevent', '0.9.1', :require => false
# gem 'growl', '1.0.3'
end
group :production do
gem 'mysql'
end

あと、チュートリアルのままだとハッシュがうごかなくて、この直しも地味にツライ(´□`。)
参考サイトさま

以上、ご参考までで

About the author
  • コメントを残す